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1 Introduction 
The software is designed to work with both TRBOnet and Motorola's generic 
option boards. You can easily configure safety-related alarms such as Man Down 
or No Movement, use the Store and Forward technique for GPS data or even 
Geofencing alarms specific to this particular radio. It works seamlessly with 
TRBOnet Enterprise or Plus, but it can also run in the standalone mode. 

1.1 Features and Benefits 
• Frequent Location Updates 
• Efficient Channel Usage 
• Fast iBeacon Detection 
• Geofencing 
• GPS Store and Forward 
• Seamless Tracking 
• Battery Status 
• Voice Recording 
• Dynamic Channel Selection 

1.2 Supported Option Boards 
• Generic option board (GOB) by Motorola (the memory capacity is 8 MB) 
• Swift option board by Neocom (the memory capacity is 512 MB) 

1.3 Supported Radio Systems 
• Direct Mode 
• IP Site Connect 
• Capacity Plus (Capacity Plus Single Site) 
• Linked Capacity Plus (Capacity Plus Multi Site) 
• Capacity MAX 
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2 Configuring Option Board 
This section describes how to configure the option board with TRBOnet Swift 
CPS. 

Notes: Make sure the Option Board capability is enabled on the radio 
channels (MOTOTRBO CPS > Channels > Zone> Channel > 
Option Board). 

 In addition, make sure that the Enhanced GNSS feature is 
disabled on the radio channels. 

2.1 Preparing Option Board 
• Connect a radio unit equipped with a Swift option board (or 

Motorola GOB) to the PC using a USB port. 
• Run TRBOnet Swift CPS. 
• Make sure that the Enable changing device mode option is set to ON 

(Tools > Options). 
• Expand the Connection menu and click USB. 
• On the Device menu, click Read, or click the Read button on the toolbar. 

Or: 
• On the File menu, click Open Sample. 
 In the folder, click the sample file intended for your type of device. Click 

Open. 
• In the Device Information pane, click Update Firmware. 
• In the Firmware update window, open the Update to menu and click the 

firmware version to which the device will be updated. 

2.2 Configuring Event Logic 
This section describes how to configure Swift Logic parameters. 
Once you have finished configuring required Swift Logic parameters: 

• On the Device menu, click Write, or click the Write button on the toolbar. 
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2.2.1 Activating Features 
• In the left pane, click Device > License Information. 
• In the right pane, click Activate features. 

 

• In the Activate features window, enter the license key. 

Notes: To obtain the license key, contact your Neocom sales 
representative. 
Your PC must be connected to the Internet when you 
click the Check button. 

• If the license key is valid, the Activate features window displays all 
features included into the license. 

• Click the Activate features button. 
 The Location Tracking license allows the option board to receive GPS 

and iBeacon location data from the radio. 
 The Personal Safety license allows the option board to use 

accelerometer to provide personal safety features. 
 The Voice Recording license allows the option board to receive voice 

recording data from the radio. 
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2.2.2 Report Profiles 
If configured accordingly, a device can collect incoming information in the 
memory, create data sequences (reports), and send them to TRBOnet Server 
over a radio channel or via a Wi-Fi connection. Reports typically include the 
current location of a connected radio and telemetry from the input pins. 
Report profiles determine what kind of information is sent to the server and how 
often. You can create as many profiles as necessary. One profile must be 
indicated as default. The default profile is loaded to the device memory at 
startup. 
To configure report settings, click Report Profiles in the Logic section of the 
navigation pane. 

 

The Report Profiles tab displays all profiles with report settings. 
• Send battery status 

Select this option so that the radio will include battery status each time it 
changes, in a report. 
See also 5.1, Battery Status. 

• Include telemetry data in each report 
Select this option so that the radio will include telemetry data in each 
report. 

In the default configuration, there are two predefined report profiles: Radio 
Report Profile and Wi-Fi Report Profile. 
You can manage report profiles as described below. 

To create a profile: 

• Click Add. On the drop-down menu, click either Radio Report Profile or 
Wi-Fi Report Profile. 

• In the Radio Report Profile/Wi-Fi Report Profile specify the report 
settings as described in section 2.2.2.1, Editing Report Profile (page 5). 
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• Click OK. 

To set a default profile: 
• Select the profile and click Set Default, 

or 
Click the appropriate radio button in the Default column. 

To edit a profile: 
• Select the profile in the list and click Edit, 

or double-click the profile. 
• Edit the report settings as described in section 2.2.2.1, Editing Report 

Profile (page 5). 
• Click OK. 

To delete a profile: 

• Click the appropriate Delete icon ( ) in the Delete column. 
The profile will be deleted and cannot be restored. If you delete the default 
profile, the last profile in the list will become the default one. 

Note: You cannot delete the last remaining profile. 

2.2.2.1 Editing Report Profile 
Specify the report settings in the Report Profile window. Click OK to save the 
profile. 

 

• Profile name 
Enter the name of the report profile. 

Depending on the selected Report Profile type (Radio or Wi-Fi), you will see the 
corresponding network settings: 
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Radio Network Settings 

• MOTOTRBO network CAI +1 
The MOTOTRBO network identity (CAI) increased by 1. This increment is 
required to send data to TRBOnet Server. Example: If MOTOTRBO CPS 
defines the network CAI 12, enter 13. 

• TRBOnet Server ID/Radio ID 
The unique radio ID of TRBOnet Server in the MOTOTRBO network. 

• TRBOnet Server port 
The port of the PC where TRBOnet Server is running (4104, by default). 

Or: 

Wi-Fi Network Settings 

• Device ID 
Enter the Radio ID of the radio equipped with the option board being 
configured. 

• TRBOnet Server IP 
The IP address of the PC where TRBOnet Server is running. 

• TRBOnet Server port 
The port of the PC where TRBOnet Server is running (4180, by default). 

GNSS Report Creation 
• Add GNSS data every (m) 

The GNSS data will be added to the report each time the specified 
distance (in meters) is traveled. 

• Add data at minimum direction change 
The minimum direction change, in degrees, at which the GNSS data is 
added to the report. 

• Add GNSS data every (sec) 
The GNSS data will be added to the report each time the specified time 
interval (in seconds) elapses. 

Report Sending 
• Type of channel for sending a report 

From the drop-down list, select one of the following options: 
 Do not send 

Creating and sending GNSS reports is disabled. 
 On the selected channel 

The radio sends reports on the currently selected channel. 
 On the data channel 

The radio sends reports on the data channel. 
• Send report every (m) 

The radio will send a report each time the specified distance (in meters) is 
traveled. 
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• Send report every (sec) 
The radio will send a report each time the specified time interval (in 
seconds) elapses. Note that in Wi-Fi Report Profile, the recommended 
value for this option is 6 sec. 

• Number of retries 
The number of retries for sending a report on the radio channel. 

• Waiting time for delivery confirmation 
The time interval, in seconds, to wait for a delivery confirmation. 

Advanced 
• Synchronize time with TRBOnet Server 

Select this option so that time on the radio will be synchronized with 
TRBOnet Server. 

2.2.3 Regions 
The Event Logic rules use geographical regions as input parameters. A region is 
an area selected on the online map and given a unique name. You can add to 
the map any polygonal regions and circular regions with a maximum radius of 
65 kilometers. 
To define regions, click Regions in the Logic section of the navigation pane. 

 

In the right pane, select the Enable module option. 
In the Presence timeout box, specify the minimum duration of stay within (if 
entered) or out (if left) of the region. This value will be used for Geofencing 
events. 
Regions appear on the map as colored areas. The region names are displayed in 
the right panel. 
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The following useful features will help you work with the map: 

To pan the map: 
• Keep the left mouse button pressed and move the mouse cursor to the 

required direction. 

To adjust the scale level: 
• Scroll the mouse wheel to zoom the map. 

To select a different map: 

• Click the Edit Map Configuration button ( ) in the right panel. 
• In the Map Configuration window, from the Tile source drop-down list, 

select the preferred map. 
• Click Apply. 

Note that in the offline mode, the map is loaded from cache. 

To select the cache folder: 

• Click the Edit Map Configuration button ( ) in the right panel. 
• In the Map Configuration window, click the Browse button next to the 

Root cache directory field. Find the destination folder and confirm the 
choice. Or, specify the folder path manually. 

• Click Apply. 
You can perform the following operations with map regions: 

To add a polygonal region: 

• Click the Create Polygonal Region button ( ). 
• Click the map where the region border will start. Draw the shape of the 

region, clicking where you want to place nodes. The added nodes 
connected with lines make a region border. 

• Double-click to finish. The first and the last nodes will be connected with a 
line. The new polygonal region will appear in the right panel under the 
Regions List. 

To add a circular region: 

• Click the Create Circular Region button ( ). 
• Click the map where the center of the region will be located. 
• Release the mouse button and move the cursor away from the center.  

The distance from the center (in km) is displayed near the region. The 
radius of a circular region is restricted to 65 km. 

• Double-click to finish. The new circular region will appear in the right 
panel under the Regions List. 
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To edit a region: 
• Double-click inside the region on the map, or in the Regions List. 

The region on the map is highlighted and all of its nodes are displayed. 
• To drag a node to a different position, click it and keep the mouse button 

pressed. To drop the node, release the mouse button. 
• To delete a node, right-click it. 
• To move the entire region, point to its central point, click and drag it to 

the new position on the map. 
• To save changes, double-click on the map. Or, press Esc to cancel editing. 

 

To import regions: 

• Click the Import from KML button ( ). 
• Confirm to replace all regions. 
• In the Import from KML window that appears browse for the desired 

*.KML file, and click Open. 

To export regions: 
• Select desired regions. 

• Click the Export to KML button ( ). 
• In the Export to KML window that appears locate the folder where you 

want to save the file, type a filename, and click Save. 

To delete a region: 
• Select the region under the Regions List and click the Delete button. 

Note: The deleted region cannot be restored with the Undo 
command. 

2.2.4 iBeacon-based Tracking 
To configure iBeacon-based tracking, select the iBeacon-based Tracking 
section in the left pane. 
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In the right pane, specify the following iBeacon-related settings: 
• Enable module 

Select this option to enable the iBeacon-based Tracking module. 
• iBeacon: Major ID/ iBeacon: Minor ID 

Enter the Major ID and Minor ID (the values or the ranges of values) of 
the iBeacons that will be used for iBeacon-based Tracking. 

• RSSI threshold 
Set the minimum signal strength, in negative decibels, of an iBeacon to be 
considered as discovered. 

• When an iBeacon is discovered 
From the drop-down list, select what to do when an iBeacon is discovered. 
 Send report normally (selected channel or data channel) 

This will add information on a discovered iBeacon to the report that 
will be sent to TRBOnet in the normal way. 

 Immediately send report (selected channel) 
This option means that the corresponding report will be sent to 
TRBOnet immediately on the selected channel. 

 Send report with interrupt (selected channel) 
This option means that the corresponding report will be sent to 
TRBOnet immediately, interrupting the current transmission, if the 
selected radio channel is busy. 

• iBeacon loss timeout 
Enter the timeout, in seconds, within which an iBeacon is not considered 
as lost. 

• When an iBeacon is lost 
From the drop-down list, select what to do when an iBeacon is lost. 
 Send report normally (selected channel or data channel) 

This will add information on a lost iBeacon to the report that will be 
sent to TRBOnet in the normal way. 
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 Immediately send report (selected channel) 
This option means that the corresponding report will be sent 
immediately on the selected channel. 

 Send report with interrupt (selected channel) 
This option means that the corresponding report will be sent 
immediately, interrupting the current transmission, if the selected 
radio channel is busy. 

• Enable debug mode 
Select this option to show debug information on the radio display. 

2.2.5 Security Tokens 
To configure the iBeacon-based user authentication, select the Security Tokens 
section in the left pane. 

 

In the right pane, specify the following Security Tokens-related settings: 
• Enable module 

Select this option to enable the Security Tokens module. 
• iBeacon: Major ID/ iBeacon: Minor ID 

Enter the Major ID and Minor ID (the values or the ranges of values) of 
the iBeacons that will be used as security tokens. 

• RSSI threshold 
Set the minimum signal strength, in negative decibels, of an iBeacon to be 
considered as discovered. 

• iBeacon loss timeout 
Enter the timeout, in seconds, within which an iBeacon is not considered 
as lost. 

• Enable debug mode 
Select this option to show debug information on the radio display. 
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2.2.6 Dynamic Channel Selection 
The Dynamic Channel Selection feature allows for automatic selection of the 
radio zone/channel depending on the geographical region and/or the proximity 
of certain iBeacons. 

• In the left pane, select the Dynamic Channel Selection section. 

 

In the right pane, specify the following Dynamic Channel Selection-related 
settings: 

• Location priority 
From the list, select the priority to use for Dynamic Channel Selection. 

• Set default channel 
Select this option and specify the default channel and zone. This 
channel/zone will be automatically set on the radio when its location is 
not available or outside designated regions/iBeacons. 
 Zone 

Enter the default zone. 
 Channel 

Enter the default channel. 
• Lock selected channel 

Select this option so that the radio will prevent the user from changing 
the automatically selected channel. 

• Add 
Click this button and specify the following Dynamic Channel Selection 
parameters: 
 Zone 

Enter the zone to be set automatically when the radio stays in the 
selected region and/or in the vicinity of the specified iBeacon(s). The 
value 0 means that the current zone won't be changed. 
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 Channel 
Enter the channel to be set automatically when the radio stays in the 
selected region and/or in the vicinity of the specified iBeacon(s). 

 Region 
From the list, select the region within which the radio must stay so that 
the specified channel/zone will be set automatically. 

 iBeacon: Major/ iBeacon: Minor 
Specify the Major ID and Minor ID of the beacon(s) in the vicinity of 
which the radio must stay so that the specified channel/zone will be set 
automatically. 

• Delete 
Click this button to remove the selected row from the Channel Selection 
Table. 

2.2.7 Custom Menu 
The Custom Menu module allows you to replace certain menu items on the radio 
(Contacts, Scan, or Zone) with your own menu items. To configure your custom 
menu, expand the Logic section and click Custom Menu in the left panel. 

 

In the Custom Menu pane, do the following: 
 Enable module 

Select this option to enable the Dynamic Channel Selection module. 
 Replace radio menu item 

From the list select one of the three radio menu items (Contacts, Scan, or 
Zone) that will be replaced with your custom menu. 
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To create a menu item: 
 Select the menu item under which you want to create a submenu and 

click Add. 

 

In the dialog that opens, enter the following: 
 Menu item icon and text 

From the drop-down list, select the icon that will be displayed in front 
of the menu name. 
In the text box, enter the name of the menu item. 

 Scenario 
From the drop-down list, select the scenario for the menu item. 
If you select 'None', the menu item will only contain submenu items 
and perform no actions. 

Note: Only enabled scenarios will be available in this list. See 
section 2.2.9, Scenarios. 

 Action 
From the drop-down list, select ether to Start or Stop the specified 
scenario. 

2.2.8 Rules 
A rule describes a specific event to which a programmed device will respond with 
a predefined sequence of actions, such as playing back tone or displaying text 
on the radio display, sending text to other radios, changing the radio channel, 
sending alarms, and other. 
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To configure rules, expand the Logic section and click Rules in the left pane. 
The Rules pane displays a predefined set of rules. You can manage the rules as 
described below. 

To create a rule: 
• Click Add and on the drop-down menu click the event type. 
• In the Create Rule window, define the rule as described in section 2.2.8.1, 

Creating/Editing a Rule (page 16). 

To create a copy of an existing rule: 
• Select the rule in the list and click Copy. 

A copy of the selected rule is added to the list. 
• Edit the rule name and settings as described below. 

To edit a rule: 
• Double-click the rule or select it in the list and click Edit. 
• Modify the rule settings in the Edit Rule window as described in section 

2.2.8.1, Creating/Editing a Rule (page 16). 

Delete a rule 
• Select the rule in the list and click Delete. 
• Confirm the deletion in the prompt dialog box. 

Enable all rules that you want to write to the device memory and be executed at 
runtime. 

To enable a rule: 
• Select the rule in the list and click Enable, 

or select the Enabled box next to the rule name. 
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2.2.8.1 Creating/Editing a Rule 
The Create/Edit Rule window is used for creating and/or editing the Event Logic 
rule. 

 

To define a rule: 

 Specify the name of the rule in the Name field (Rule: Name). 
 Specify the state of the rule (State: Disabled/Enabled). 

 In the Event pane, specify the properties of the event. For a brief 
description of the event, click the "i" icon at the window's top right. 

 In the right pane, click Add Step. This will add an additional step to the 
set of actions. Double-click the step that appears and enter the 
duration, in seconds. If you click Add Step > Add Restart, a 'Restart all 
steps' action will appear at the bottom of the set of steps/actions. 

 In the right pane, select a step and click Add Condition. You can add 
as many conditions as required. Configure conditions as described in 
section 2.2.8.3, Conditions (page 19). 

 In the right pane, select a step add click Add Action. Configure each 
action as described in section 2.2.8.4, Actions (page 21). 

 Click OK to save the rule. 
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2.2.8.2 Events 
The following table summarizes information about all supported events and 
their configurable properties. 

Event Description 

Start of Device This event is triggered when the radio starts up. 

Swift Command This event is triggered when the Swift command is received from 
TRBOnet Server. Properties: optional parameters 1, 2. 

Telemetry Input This event is triggered when the status of any I/O pin has changed 
on the device. 
Properties: 

 Telemetry: Select the Input pin #. 
 Trigger: Select the type of change occurring to the pin (turned 

on, off or toggled) 

Wi-Fi Network This event is triggered when a Wi-Fi network is 
connected/disconnected. 
Properties: 

 Network trigger: Select whether the Wi-Fi network is 
connected or disconnected. 
Wait timeout: Enter the minimum duration of staying 
connected/disconnected. 

Sudden Acceleration 
Change 

This event is triggered when the radio acceleration experiences a 
sharp change along the given axis. This event can be used, for 
example, to detect sudden braking of the vehicle. 
Properties: 

 Axis: Select the axis along which to detect the sudden change 
of acceleration. 

 Acceleration threshold: The maximum acceleration that 
shall be exceeded to trigger the event. 

 Enable debug mode: Select this option to show debug 
information on the radio display. 

Rollover Detection This event is triggered when the mobile radio tilt is below the 
threshold angle for a time longer than the pre-alarm duration. 

 Threshold angle: The minimum vertical angle (in degrees) at 
which the radio is still considered up. 

 Pre-alarm duration: The timeout (seconds) after detecting 
the radio tilt. 

Note: After installing the radio in the working position in a car, you 
need to set a custom axis orientation of the accelerometer. 
This is done by clicking Set a custom axis orientation of 
the accelerometer in the Service page. 

 Enable debug mode: Select this option to show debug 
information on the radio display. 
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Event Description 

Crash Detection This event is triggered when the radio acceleration exceeds the 
impact threshold, the speed drops to zero within the idle timeout, 
and then there is no movement for the duration of the wait 
timeout. 

 Impact acceleration threshold: The maximum acceleration 
that shall be exceeded to suspect a car crash. 

 Wait timeout: The timeout, in seconds, that starts after the 
suspected car crash and during which no acceleration 
measurements are taken. 

 Acceleration threshold: The minimum acceleration that 
must be gained during the control time to confirm the normal 
speed mode. 

 Idle timeout: The timeout, in seconds, that starts after the wait 
timeout. 

Lone Worker This event is triggered when there is no user activity for a time 
longer than the response time. The timer will restart after pressing 
any radio button or knob. 

 Response time: The timer, in seconds, that restarts after a 
button push, a talk, or use of the channel selector was detected 
on the radio. 

No Movement This event is triggered when the radio acceleration is below the 
threshold for a time longer than the wait time. 

 Acceleration threshold: The minimum acceleration at which 
the radio is still considered to be at normal speed. 

 Wait time: The timeout, in seconds, that starts after the radio 
acceleration has fallen below the threshold. 

Man Down This event is triggered when the radio tilt is below the threshold 
angle for a time longer than the pre-alarm duration. 

 Threshold angle: The minimum vertical angle, in degrees, at 
which the radio is still considered up. 

 Pre-alarm duration: The timeout (seconds) after detecting 
the radio tilt. 

 Enable debug mode: Select this option to show debug 
information on the radio display. 

Note: Before enabling this event, you need to set a custom axis 
orientation of the accelerometer. This is done by clicking Set 
a custom axis orientation of the accelerometer in the 
Service page. 

Speed Limit This event is triggered when the measured speed exceeds or falls 
below the threshold. 

 Speed: The math operator. Values: greater than, less than. 
 Threshold: The maximum or minimum allowed speed in 

kilometers per hour. 

Note: The speed measurement error may be as high as 5 to 10%, 
depending on the type of a two-way radio (less for mobile, 
higher for portable) and on the satellite signal reception 
quality. 
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Event Description 

Geofencing This event is triggered when the radio enters/exits the designated 
region for a time longer than the wait timeout. 
Properties: 

 Region: Select the region the borders of which are monitored. 
 Direction: Select if the region is entered or left. 

Radio Call This event is triggered when an incoming or outgoing call starts, or 
a call (either incoming or outgoing) ends. In addition, you can 
select the call type for this event. 

 Call trigger: Select one of the three triggering conditions. 
 Call from: Select the type of the call. 
 Enable debug mode: Select this option to show debug 

information on the radio display. 

Radio Channel This event is triggered when a different channel and/or zone is 
selected on the radio. 

 Zone: Enter the zone number. 
 Channel: Enter the channel number. 

Radio Button This event is triggered when the designated radio button is 
pressed/released. 

 Button: Select the radio button. 
 Action: Select the type of action. This can be Short press, 

Long press, or Release. 

Security Tokens This event is triggered when one of the following Security Tokens 
event has occurred: 

 User Logged In 
 User Logged Out 
 Token Not In Range. 

iBeacon This event is triggered when an iBeacon is discovered/lost. 

 iBeacon trigger: Select whether the iBeacon is discovered or 
lost. 

 Major ID: Enter the beacon’s major ID exactly as specified in 
the iBeacon device. 

 Minor ID: Enter the beacon’s minor ID exactly as specified in 
the iBeacon device. 

Start of Device This event is triggered when the radio starts up. 

 

2.2.8.3 Conditions 
In the right pane of the Create/Edit Rule window, add one or more conditions 
for the event to be handled. 

Note: Adding conditions to a rule is optional. If you add multiple 
conditions, ALL OF THEM must be TRUE for the actions to be 
executed. 
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To add a condition: 
• In the right pane of the Create/Edit Rule window, select a step and click 

Add Condition. In the drop-down menu, click the desired condition. 
• In the dialog box that opens, specify the required condition parameters. 
 Geofencing 

In the Geofencing Condition dialog box specify the following 
parameters: 
• Region 

From the drop-down list, select the desired region. 
• Position 

From the drop-down list, select 'Inside' or 'Outside' position in a 
region. 

 Selected Radio Channel 
In the Selected Radio Channel Condition dialog box, specify the 
Channel and Zone. 

 iBeacon In Range 
In the iBeacon In Range Condition dialog box specify the iBeacon's 
Major ID and Minor ID. 

 Flag State 
In the Flag State Condition dialog box specify the Flag (a number from 
1 to 32) and its State (On/Off). 

 Telemetry Input State 
In the Telemetry Input State Condition dialog box specify the 
Telemetry input (Input 1 – Input 8) and its State (On/Off). 

Once added, the new condition will appear at the beginning of the 
corresponding step. The order of conditions in the list cannot be changed and 
does not affect the logic. 
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To edit condition settings: 
• Double-click the desired condition. 

In the dialog box that opens, edit the required condition parameters. 

To delete a condition: 
• Select the desired condition and click the Delete button. 

2.2.8.4 Actions 
In the right pane of the Create/Edit Rule window, add one or more actions to 
execute when the event has occurred and all conditions have been confirmed. 

To add an action: 
1. In the right pane of the Create/Edit Rule window, click Add Action and in 

the drop-down menu click the desired action. 
2. In the dialog box that opens, specify action properties and click OK. 

 

A new action with the specified name appears at the last position in the right 
pane of the Create/Edit Rule window. Use Up and Down arrow buttons to 
adjust the execution order of actions. 
To delete an action, click the Delete button. Double-click the required action to 
open its properties for editing. 
The following table summarizes information about all supported actions and 
their configurable properties. 
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Action Description 

Play Tone This action forces the radio to play back the specified tone. Properties: 

 Tone: The tone to be played back. 
 Tone Type: Choose whether to play the tone momentarily or 

repetitively. 
 Volume shift: The volume boost (in MOTOROLA’s units of measure). 

Change Volume This action forces the radio to change the volume of its speaker. 

Properties: 

 Action: Select the action to be executed (Increase Volume or 
Decrease Volume). 

Play Announcement This action forces the radio to play back a pre-recorded voice 
announcement. 

 Voice Announcement: Select one of the pre-recorded voice 
announcements. 

Display Text This action forces the radio to display text. 

Properties: 

 Text: Enter the text to display on the radio. 
 Position: The display line from which the text starts. Options: Line 1, 

Line 2, Line 3, Line 4. 
 Alignment: Select the alignment of the text. 
 Font: Select the font style (Normal or Bold). 

Send Text This action forces the radio to send text to a specified radio or radio 
group. Properties: 

 Destination: The recipient of the message. Values: radio, radio 
group. 

 Radio ID: The radio ID of the recipient. 
 Text: The message to be sent. 

Send DTMF This action forces the radio to send the specified DTMF sequence on the 
radio channel. Properties: 

 Sequence: The sequence of digits to be sent. 
 Pretime: The duration of silence (ms) prior to sending the first 

DTMF tone. 
 Duration: The duration of the DTMF tone digits in milliseconds (ms). 
 Interval: The duration of the intervals between the DTMF tone digits 

in a transmission sequence in milliseconds (ms). 

Send Swift Alarm This action forces the radio to send an alarm to TRBOnet Server. The 
alarm type will depend on the triggered event (Crash Detection, Lone 
Worker, Man Down, No Movement, etc.). 

Save Event This action forces the radio to save the corresponding alarm event (along 
with the coordinates of the radio) to the option board's memory. 

Manage Emergency This action activates/deactivates the alarm mode on the radio. 

Set Radio Channel This action forces the radio to select a different radio channel/zone. 
Properties: 

 Channel: The radio channel to be set. 
 Zone: The zone to be set. 

Note: These are numerical values that are represented in MOTOTRBO 
CPS, Channels>Zone>Channel (in the Position column). 
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Action Description 

Send Report This action will send a report to TRBOnet Server. 

 Priority: 
o Normal (selected channel or data channel) 
o High (selected channel) 
o With Interrupt (selected channel) 

This priority means that a report will be sent immediately over 
the selected channel, interrupting the current transmission, if 
the channel is busy. 

Select Report Profile This action forces a device to use the specified profile with report settings. 

Note: A profile with report settings defines rules for sending reports to 
TRBOnet Server. See also section 2.2.2, Report Profiles (page 4). 

 Profile: Select the report profile to switch to. 

Send Swift 
Command 

This action will send a Swift command to TRBOnet Server. 

 Command: Select the Swift command to be sent. 
 Parameter: Enter the parameter if the Swift command contains a 

parameter. 
 Destination: Select one of the destinations (TRBOnet, Radio, or 

Radio group). 
 Radio/Group ID: Enter the Radio/Group ID if the Radio or Radio 

group are selected as the destination. 
 Target Device: Select the device connected to the target radios: an 

option board (Swift OB, GOB) or a DT series controller (Swift DT200/ 
DT600). 

 Priority: The values are: 'Immediately send to TRBOnet' and 
'Immediately send to TRBOnet with interrupt'. The latter option 
means that the selected command will be sent immediately, 
interrupting the current transmission, if the radio channel is busy. 

Set Telemetry 
Output 

This action will set the selected telemetry output to the specified state. 

 Action: Select the action for the output (Toggle, On, O). 
 Output: Select the radio's output to perform the specified action on. 

Set Flag This action will set the selected flag to the specified state. 

 Action: Select the action for the flag (Toggle, On, Off). 
 Flag: Specify the flag (a number from 1 to 32). 

Set Power Level This action will set the radio’s transmission power level for the current 
channel. 

 Power: The values are 'Low' and 'High'. 

Set Display 
Brightness 

This action will set the radio display brightness to a specified level. 

 Brightness: The values are 'Increase' (one step), 'Decrease' (one 
step), 'Maximum', 'Minimum' and 'Default' 

Lock Radio This action will lock/unlock the radio's keyboard. 

Press Button This action will short-press the specified Accessory Button on the radio 
(No Dot Button, 1-Dot Button, or 2-Dot Button). 

 Short press: Select the desired Accessory Button. 

Log Out User This action will log out the user (deallocate the radio). 
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Action Description 

Manage Scenario This action will start/stop the desired scenario. See section 
2.2.9, Scenarios. 

 Scenario: Select the desired scenario. 
 Action: Select either to Start or Stop the desired scenario. 

 

2.2.9 Scenarios 
A scenario is a sequence of steps/conditions/actions that can be then 
started/stopped in a particular place of a rule by clicking 
Add Action > Manage Scenario. 
To configure scenarios, expand the Logic section and click Scenarios in the left 
panel. 

 

The Scenarios pane displays a set of the scenarios. You can manage the 
scenarios as described below. 

To create a scenario: 
• In the Scenarios pane, click Add. 
• In the Create Scenario window, define the of steps/conditions/actions as 

described in section 2.2.9.1, Creating/Editing a Scenario (page 25). 

To create a copy of an existing scenario: 
• Select the scenario in the list and click Copy. 

As a result, a copy of the selected scenario is added to the list. 
• Edit the scenario name and settings as described below. 

To edit a scenario: 
• Double-click the scenario or select it in the list and click Edit. 
• Modify the scenario settings in the Edit Scenario window as described in 

section 2.2.9.1, Creating/Editing a Scenario (page 25). 



 

2.3 Mass Configuration 25 

TRBOnet Option Board – Configuration Guide 

Delete a scenario 
• Select the scenario in the list and click Delete. 

2.2.9.1 Creating/Editing a Scenario 
The Create/Edit Scenario window is used for creating and/or editing the 
scenario. 

 

• Specify the name of the scenario in the Name: field. 
• Click Add Step. This will add an additional step to the set of actions. 

Double-click the step that appears and enter the duration, in seconds. If 
you click Add Step > Add Restart, a 'Restart all steps' action will appear 
at the bottom of the set of steps/actions. 

• Click Add Condition and in the drop-down menu, click the desired 
condition. 
For a description of conditions, see section 2.2.8.3, Conditions. 

• Click Add Action and in the drop-down menu click the desired action. 
For a description of conditions, see section 2.2.8.4, Actions. 

• Use Up and Down arrow buttons to adjust the execution order of 
steps/actions. 

2.3 Mass Configuration 
You can configure multiple option boards at once by using the Mass 
Configuration mode. The OTA connection is used for over-the-air programming 
of endpoint devices such as an option board ST002 installed into a MOTOTRBO 
radio. 

• On the toolbar, click Tools > Mass Configuration. 
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• In the Mass Configuration page, enter the following parameters: 
 Device type 

From the drop-down menu, select 'Swift OB, GOB'. 
 OTA Connection 

In this section, specify the OTA (over-the-air) Connection-related 
settings. 
• Gateway 

The gateway that can establish an IP connection with TRBOnet Swift 
CPS and that can communicate with the device over the air. 
Values: TRBOnet Server, Swift IP Gate: Swift A100/ A200 

• IP Address 
The IP address of the gateway selected above. 

• Port 
This is the Forward Data service port of the TRBOnet Server (if 
selected above). Default: 4011. 
To get the port number, launch the TRBOnet Enterprise (PLUS) 
Server application and select Radio Systems > Services in the left 
pane. Find the port number under the Forward Data service 
option. 

Note: Make sure that the Forward Data service option is 
selected (see section 4.1, TRBOnet Server). 

• Response timeout 
The time period, in seconds, to wait for a response from the server 
side (TRBOnet Server, Swift IP Gate). 

 File 
Enter the full path name for the configuration file (*.swr) that will be 
sent to the radios specified below. 
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 Radio ID range 
Enter the range of Radio IDs to which the configuration file selected 
above will be sent. 

Note: Separate each Radio ID with a comma, for example, 
"105,106,111", or enter the range using the following 
example: "105-111". 

 Retry count 
Enter the number of retries allowed. 

• Once you have specified the desired configuration settings, click Start. 
 

3 Voice Recording 
The Voice Recording tool available in TRBOnet Switch CPS allows you to retrieve 
call recordings from the radio and listen to them by using the TRBOnet Player. 

Note: In the Swift ST002 option board, the amount of memory for 
voice records is limited to 256 MB. 

• In the left pane, click Device > Voice Recording. 

 

• In the Voice Recording pane on the right, choose the appropriate time 
period and click View Call Log. 
In the Sessions table, you will see the list of audio sessions. 

• Select a record or a group of records in the table and click the Download 
button. 
The downloaded record(s) will be marked as checked in the State field. 
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• Once downloaded, the records can be listened to by clicking the Play 
button. 
The TRBOnet Player will open and start playing the selected audio 
record(s). 

• To save downloaded records, click the Save button. 
In the Save As dialog box, locate the folder where you want to save the 
audio file, specify the file name, and click Save. 

Note: The audio records will be saved in the TNA format, which 
is a proprietary audio format that contains additional 
information about radio calls, such as radio ID, start time, 
end time, and other parameters. This format provides 
more details about call participants and allows easy 
navigation within recorded audio files. 

 

4 Configuring TRBOnet Enterprise 
This section describes how to configure TRBOnet Enterprise software to take 
advantages of using option boards. 

4.1 TRBOnet Server 
• Run TRBOnet Enterprise Sever. 
• In the Configuration pane, select Radio Systems > Services. 

 

• In the Services pane: 
 Select the Swift.Tracker v.2 service option and make sure the port 

number is 4104. 
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 Select the Swift.Tracker v.2 service (IP channel) option and make 
sure the port number is 4180. 

 Select the Forward Data service option and make sure the port 
number is 4011. 

Note: Selecting the Forward Data service option is required 
for using Mass Configuration in TRBOnet Swift CPS. 

4.2 TRBOnet Dispatch Console 
• Run TRBOnet Enterprise Dispatch Console. 
• Go to Administration > Radios. 
• Double-click the desired radio in the list of registered radios. 

The Digital Radio dialog box opens: 

 

 Extended Device 
From the drop-down list, select Swift Option Board 2.0. 

 Location Service>Location Source 
From the drop-down list, select Extended device. 

 Location Service>Location Profile 
From the drop-down list, select the location profile to apply. 

Note: In the applied Location Profile (Administration > 
Location Profile), set the Interval parameter to a value 
two-three times as large as that specified in TRBOnet 
Swift CPS (Logic > Report Profiles > Radio Report 
Profile > Send report every X sec, see section 2.2.2.1, 
Editing Report Profile). 
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5 Using Option Board Features in Dispatch 
Console 

5.1 Battery Status 
• Select a radio in the Radio List and hover the mouse pointer over it: 

 

In addition to the common information, you'll see the battery status 
received from the radio. 

Note: The version of TRBOnet Enterprise must be 5.2.0.1359 or later. 
The Swift ST002 device firmware version must be 03.00.13 or 
later. If the radio is equipped with an Impres battery, the 
dispatcher will be able to see the percentage remaining 
battery level. Otherwise, the radio will send an alert in the case 
of a low battery level. 
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5.2 Downloading Location Data 
• Right-click a radio in the Radio List, and on the context menu, choose 

Monitoring > Download Stored Location Data. 

 

• In the dialog box, specify the following parameters: 
 Start time 

Specify the date/time starting from which to load location data from 
the radio's option board. 

 Period 
Specify the time period, in minutes, for which to load location data 
from the radio's option board. 

 Click Load to start loading location data. 
 Once you have finished loading location data, click the Play button and 

see the route made by the radio user on the map. 
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5.3 Automatic Data Retrieval 
The Automatic Data Retrieval task is used to automatically retrieve missing 
location data from the radio's option board. 

• Go to Administration, Tasks. 
• In the Tasks pane, click Add > Automatic Data Retrieval (Swift GPS). 

 

• In the dialog box, specify the following parameters: 
 Maximum number of simultaneous requests  

Specify the maximum number of radios being requested at the same 
time. 

 Retrieve missing locations if the data gap exceeds 
TRBOnet Server automatically checks whether the location data is 
continuous. If it detects data gaps between any consecutive location 
data that exceed this value, it will attempt to retrieve missing 
information. 
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 Don't retrieve missing locations older than 
TRBOnet Server doesn't check location updates for consistency if they 
are older than this value in seconds, minutes, or hours. 

 On the Radios tab, specify the radio(s) to retrieve location data from. 
• In the list of tasks, activate the Automatic Data Retrieval (Swift GPS) 

task by selecting the box next to the task name. 

5.4 Automatic Voice Download 
The Automatic Voice Download task is used to automatically retrieve voice data 
from the radio's option board when the radio is in WiFi zone. 

• Go to Administration, Tasks. 
• In the Tasks pane, click Add > Automatic Voice Download (Swift). 

 

• In the dialog box, specify the following parameters: 
 Maximum number of simultaneous requests 

Specify the maximum number of simultaneously requested radios. 
 Save to 

Specify the path where to save voice data on your PC. 
 On the Radios tab, specify the radio(s) to retrieve voice data from. 

In the list of tasks, activate the Automatic Voice Download (Swift) task by 
selecting the check box next to the task name. 
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