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1 Introduction

The software is designed to work with both TRBOnet and Motorola's generic
option boards. You can easily configure safety-related alarms such as Man Down
or No Movement, use the Store and Forward technique for GPS data or even
Geofencing alarms specific to this particular radio. It works seamlessly with
TRBOnNet Enterprise or Plus, but it can also run in the standalone mode.

1.1  Features and Benefits

e Frequent Location Updates
e Efficient Channel Usage

e FastiBeacon Detection

e Geofencing

e GPS Store and Forward

e Seamless Tracking

e Battery Status

e Voice Recording

¢ Dynamic Channel Selection

1.2 Supported Option Boards

e Generic option board (GOB) by Motorola (the memory capacity is 8 MB)
e Swift option board by Neocom (the memory capacity is 512 MB)

1.3  Supported Radio Systems

e Direct Mode

e [P Site Connect

e Capacity Plus (Capacity Plus Single Site)

e Linked Capacity Plus (Capacity Plus Multi Site)
e Capacity MAX

2 1 Introduction
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2 Configuring Option Board

This section describes how to configure the option board with TRBOnet Swift
CPS.

Notes: Make sure the Option Board capability is enabled on the radio
channels (MOTOTRBO CPS > Channels > Zone> Channel >
Option Board).

In addition, make sure that the Enhanced GNSS feature is
disabled on the radio channels.

2.1 Preparing Option Board
e Connect a radio unit equipped with a Swift option board (or
Motorola GOB) to the PC using a USB port.
e Run TRBOnet Swift CPS.

e Make sure that the Allow changing device firmware type option is set
to ON (Tools > Options).

e Expand the Connection menu and click USB.

e On the Device menu, click Read, or click the Read button on the toolbar.
Or:

e On the File menu, click Open Sample.

= In the folder, click the sample file intended for your type of device. Click
Open.

¢ Inthe Device Information pane, click Update Firmware.

¢ In the Firmware update window, open the Update to menu and click the
firmware version to which the device will be updated.

2.2 Configuring Event Logic

For how to configure Swift Logic parameters, refer to section 4.5, Swift Event Logic
in TRBOnet Swift CPS User Guide.

Once you have finished configuring required Swift Logic parameters:
e On the Device menu, click Write, or click the Write button on the toolbar.

2.2 Configuring Event Logic 3
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2.2.1 Activating Features

¢ In the left pane, click Device > License Information.
e Inthe right pane, click Activate features.

Activate features

=\
|| Activate features on device.

License key | sxssssssssrrsreccrsssssees ] &

Company Test_ Neocom Software

80 8

Location Tracking FELOOT v
Personal Safety #ELO10 70 13 v
Custom Service #ELO30 70 7 v
Voice Recording #ELDS0 60 14 v

Activate features = Activate demo mode = Restore features

¢ Inthe Activate features window, enter the license key.

Notes: To obtain the license key, contact your Neocom sales
representative.

Your PC must be connected to the Internet when you
click the Check button.

o If the license key is valid, the Activate features window displays all
features included into the license.
e Click the Activate features button.

= The Location Tracking license allows the option board to receive GPS
and iBeacon location data from the radio.

= The Personal Safety license allows the option board to use
accelerometer to provide personal safety features.

= The Voice Recording license allows the option board to receive voice
recording data from the radio.

neocom
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MOTOTRBO GOB (Event Logic)-Sample_GOB (Swift Logic) X

) Device License Information
Device Information

License Information The following features are available for the device.

Voice Recording Location Tracking: () Activated

Service
E Logic Personal Safety: (&) Activated
Genere! Custom Service: () Activated
Report Profiles
+ Radio Report Voice Recording: (&) Activated
EGPS Report
Regions
Modules
Dynamic Channel.. © Activate features
iBeacon Settings © Additional information
Rules
Man Down

No Movement
Lone Worker
Geofencing

Scenarios

Connection

2 Configuring Option Board
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2.2.2 Mass Configuration

You can configure multiple option boards at once by using the Mass
Configuration mode. The OTA connection is used for over-the-air programming
of endpoint devices such as an option board ST002 installed into a MOTOTRBO
radio.

e On the toolbar, click Tools > Mass Configuration.

neocom
@ software

Mass Configuration

Device type Swift 0, GOB_ ~
OTA Connection

Gateway TREONet Server
1P Address wiziold v
port 011

Response timeout, sec | 15

C:ProgramData\Neocom Software\TREONet Swift CPS\Samples\Sample_GOB (Swift Logic).swr

¢ Inthe Mass Configuration page, enter the following parameters:

= Device type
From the drop-down menu, select 'Swift OB, GOB'.

= OTA Connection
In this section, specify the OTA (over-the-air) Connection-related
settings.

e Gateway
The gateway that can establish an IP connection with TRBOnet Swift
CPS and that can communicate with the device over the air.
Values: TRBOnet Server, Swift IP Gate: Swift A100/ A200

o IP Address
The IP address of the gateway selected above.

e Port
This is the Forward Data service port of the TRBOnet Server (if
selected above). Default: 4011.
To get the port number, launch the TRBOnet Enterprise (PLUS)
Server application and select Radio Systems > Services in the left
pane. Find the port number under the Forward Data service
option.

Note: Make sure that the Forward Data service option is
selected (see section 4.1, TRBOnet Server).

2.2 Configuring Event Logic 5
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¢ Response timeout
The time period, in seconds, to wait for a response from the server
side (TRBOnet Server, Swift IP Gate).
= File
Enter the full path name for the configuration file (*.swr) that will be
sent to the radios specified below.

= Radio ID range
Enter the range of Radio IDs to which the configuration file selected
above will be sent.

Note: Separate each Radio ID with a comma, for example,
"105,106,111", or enter the range using the following
example: "105-111".

= Retry count
Select this option and enter the number of retries allowed.

e Once you have specified the desired configuration settings, click Start.

6 2 Configuring Option Board
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3 Voice Recording

The Voice Recording tool available in TRBOnet Switch CPS allows you to retrieve
call recordings from the radio and listen to them by using the TRBOnet Player.

Note: In the Swift ST002 option board, the amount of memory for
voice records is limited to 256 MB.

¢ Inthe left pane, click Device > Voice Recording.

neocom
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File

(L ERE Al MOTOTRBO GOB (Event Logie) - USB/Wi-Fi (192.168.10.1) %

Device Information Voice Recording

O Byperiod O Lastday O Lastweek @ Lastmonth

View Call Log

Report Profiles O 11/28/2018%:02:36 Al 2419244 Group Call 64291

* g n—-———-—

Regions 11/28/2012 %:05:15 Al 2418403 oup Call 64201 00:01
Modules J
Rules

12/3/2018 2:23:30 PM 2806181 rivate Call 64250 7 00:02

00:01

12/4/2018 8:52:43 AM 2872734 roup Call P 0

Gro
P

@ 12/3/2018 4:21:57 PM 2813288 Group Call 64000 16777215
G 00:01
G

- -

[9) 12/4/2018 1:30:46 PM 2889417 roup Call 7 0 00:03

4250 P 1 nons

12000
Sessions 9 Calls 12
¥ Download » Play Save..

¢ Inthe Voice Recording pane on the right, choose the appropriate time
period and click View Call Log.

In the Sessions table, you will see the list of audio sessions.

e Select arecord or a group of records in the table and click the Download
button.
The downloaded record(s) will be marked as checked in the State field.

e Once downloaded, the records can be listened to by clicking the Play
button.
The TRBOnet Player will open and start playing the selected audio
record(s).

e To save downloaded records, click the Save button.
In the Save As dialog box, locate the folder where you want to save the
audio file, specify the file name, and click Save.

Note: The audio records will be saved in the TNA format, which
is @ proprietary audio format that contains additional
information about radio calls, such as radio ID, start time,
end time, and other parameters. This format provides
more details about call participants and allows easy
navigation within recorded audio files.

2.2 Configuring Event Logic 7
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Configuring TRBOnet Enterprise

This section describes how to configure TRBOnet Enterprise software to take

advantages of using option boards.

4.1 TRBOnet Server
e Run TRBOnet Enterprise Sever.
¢ Inthe Configuration pane, select Radio Systems > Services.
Configuration Services
a Service
O Metwork | Automatic Registration service (ARS)
# Redundancy Port: 4005 =] [+ rsat
= Remote Access Restriction
Database | Telemetry service (TLM)
(2 Reports Port: 4008
/ ied?:;:ja;:f;nn;:m | Text Messages service (TMS)
L.\ Geocoding Servers Port: 4007
! Radio Systems | Location service (LRRP / Indoor)
g Psct '
B LePEt
gy Control Station #1
:Ej Selex #1 [N ]
B PTT over Cellular
)’_ Advanced Settings
[ PoC Gateway #1 | Swift. Tracker v.2 service
T Teltonika Port:
Ei R?mohe Agents | Swift. Tracker v. 2 service (IP channel)
| Friendly Servers
ﬂ Fhone Connect v Port: v
Set Defaults Apply Cancel
¢ Inthe Services pane:
= Select the Swift.Tracker v.2 service option and make sure the port
number is 4104.
= Select the Swift.Tracker v.2 service (IP channel) option and make
sure the port number is 4180.
= Select the Forward Data service option and make sure the port
number is 4011.
Note: Selecting the Forward Data service option is required
for using Mass Configuration in TRBOnet Swift CPS.
4.2 TRBOnet Dispatch Console

e Run TRBOnet Enterprise Dispatch Console.

¢ Go to Administration > Radios.
e Double-click the desired radio in the list of registered radios.

The Digital Radio dialog box opens:

4 Configuring TRBOnet Enterprise
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Digital Radio: Radic 125 X
General | Logical Groups] Addttional | SIP Account] Camerasl
Radio Name: |Radio 125 |
Radio 10 125 3| Mpc I ul 3
Radio Groups: |AII | |
Home Group: |Nune | |
Use icon: |® Portable Radios K 2 |
Extended Device: @ift Option Board 2.0 9 Test | ~
Location Service
Location Source: @tended device ) v |
Location Profile:  ([Location Profile #1 D) v |
Telemetry Service
TLM Source: |Bui|t—in Telemetry ~ |
TLM Prafile: |(DaFauIt) [ |
Text Messages Service
THZ S e TR —— . [
Hide Advanced Sethings
Cancel

= Extended Device
From the drop-down list, select Swift Option Board 2.0.

= Location Service>Location Source
From the drop-down list, select Extended device.

= Location Service>Location Profile
From the drop-down list, select the location profile to apply.

Note: In the applied Location Profile (Administration >
Location Profile), set the Interval parameter to a value
two-three times as large as that specified in TRBOnet
Swift CPS (Logic > Report Profiles > Radio Report >
Send report every X sec).

Location Profile (Extended device) x

General | Management

Name: |Locatinn Profile #1

Description:

Positioning mode: ‘iBEaEUI‘I Indoor fOutdoor j
GPS data: ‘Latib.lde, Longitude, Predision, Direction, Speed j
Interval: ‘ 240]0 i‘ I second

OK Cancel

4.2 TRBOnet Dispatch Console

nheocom
software
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5 Using Option Board Features in Dispatch
Console

5.1 Battery Status

e Select aradio in the Radio List and hover the mouse pointer over it:

125

@=

Capadity Plus #1
( Battery: 71%
(i) Off Duty

Accepted #AD0003

GPS5: 19.09.2017 16:03:44
Speed: 0,7 km/h
Altitude: Unknown
Latitude: 59°56'25,35" N
Longitude:  30°16'48,32°E

7 lin. Vasilyevskogo Ostrova,
34, sankt-Peterburg, Russia,
199034

In addition to the common information, you'll see the battery status
received from the radio.

Note: The version of TRBOnet Enterprise must be 5.2.0.1359 or later.
The Swift ST002 device firmware version must be 03.00.13 or
later. If the radio is equipped with an Impres battery, the
dispatcher will be able to see the percentage remaining
battery level. Otherwise, the radio will send an alert in the case
of a low battery level.

5.2 Downloading Location Data

¢ Right-click a radio in the Radio List, and on the context menu, choose
Monitoring > Download Stored Location Data.

10 5 Using Option Board Features in Dispatch Console
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Download Stored Location Data X

Date

27.09.2017 12:10:31

GFS Data

: 59°56'28,12" N; Longitude: 30

Speed

27.09.2017 12:16:09 Latitude: 53°55'26,53" N; Longitude: 30°16"... 0,0 km/h
27.09.2017 12:17:28 Latitude: 5955'26,65" N; Longitude: 30°16"... 0,0 km/h
27.09.2017 12:17:47 Latitude: 59°56'26,80" N; Longitude: 30°16"... 0,0 km/h
27.09.2017 12:18:17 Latitude: 59°55'26, 76" N; Longitude: 30°16"... 0,0 km/h
27.09.2017 12:18:28 Latitude: 59°55'26,80" N; Longitude: 30°16"... 0,0 km/h
27.09.2017 12:18:47 Latitude: 59°56'27,58" N; Longitude: 30°16"... 0,0 km/h
27.09. 2017 17:19:07 | atitude: 59%56'76.837 N: | annitude: 30°16"... 0.0 km/h =
Total: 186
® ) @ @ Save to Database Load
Radio: |® 13 V|
Color: |- 50; 205; 50 v|
|

Gart tme

: |27.09.2017 12:00 )

C_ Period:

|70

ﬂ min@

[] optimize Route {aroup all nearest points)
|:| Automatic correct GPS errors

Configure
Follow the radio on map

¢ Inthe dialog box, specify the following parameters:

= Start time
Specify the date/time starting from which to load location data from
the radio's option board.

* Period
Specify the time period, in minutes, for which to load location data
from the radio's option board.

= Click Load to start loading location data.

= Once you have finished loading location data, click the Play button and
see the route made by the radio user on the map.

File View Map Tools Help

]S
[+(@] [ Jintercom [ B[] B[ Jprivate call [=][+] ) Y P slot [][«][e]

Location Tracking

BEEh &Y YR

| Map

swslqo

5 1: Line free
st 2
My Map

[»][«][e]

a l& Online Dispatehers (1)

& voice Recording

Evultviem-.r

EI,, -

Recent Cals/Events

Administrator
o O%mme‘ ndoor (1) L O 5% (=] Fiter | @] @ QBT \| Show Beacons: Al ~ o Ruler \ FindonMap= & 7 Route~ &
< I \ Download Stored Location Data X
s - ! :
() Online, GPS Fixed (0) 5 Gt al ESPats [ soeed [ ]
\ 27.03.2017 12:45:22  Latitude: 59°56'25,80° N; Longitude: 30°16'... 0,0 km/h -
© () Online, No GPS (1) ‘-\ 27.08.2017 12:45:24  Latitude: 58°5625,30° N; Longitude: 30°16'... 0,0 km/h
®® s (TN =1 ‘_‘ ;) 27.09.2017 12:45:34  Latitude: 59°56'25,84° N; Longitude: 30°16',.. 0,0 km/h Il
- o 27.08.2017 12:45:36 Latitude: 59°5 Longitude: 30 0,0km/h
& () omins ) \ e P
Al 27.08.2017 12:46:03  Latitude: 59°56'26, Longitude: 30°16... 0,0 km/h
27.08.2017 12:46: 10 Latitude: 53°56'25, ; Longitude: 30°16'... 0,0 km/h

27.09.2017 12:46:11
27.08.2017 12:46:18

Latitude: 59°56°25,
Latitude: 59°56'25.91° N: Lonaitude: 30°16'

" N; Longitude: 30°16'... 0,0 km/h

Period:

Total: 297
ORONC) Save to Database Load
Radio: @) 13 ~]
Color: | 50; 205; 50 ~
Start tme: [27.09.2017 12:00 ~]

%0 = minutes

L] optimize Route (group all nearest points)
[ Automatic correct GPS errars

Confiqure
Follow the radio on map

RecentCals | RequestToTalk | RadioState | ActiveTasks | ActiveRoutes  User Activity | Beacons | BeaconEvents | Taglist

B127000 £ @& B | & Administator | (8 Licensed to: dema

5.2 Downloading Location Data

| @ Active -

11
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5.3 Automatic Data Retrieval
The Automatic Data Retrieval task is used to automatically retrieve missing
location data from the radio's option board.
e Go to Administration, Tasks.
e In the Tasks pane, click Add > Automatic Data Retrieval (Swift GPS).

Automatic Data Retrieval (Swift GPS) =
Task name: ‘Momaﬁc Data Retrieval (Swit GPS)| |
General Radios
Maximum number of simultaneous requests: 3 El:
Data upload
Retrieve missing locations if the data gap exceeds: 30 EI: seconds
Do not retrieve missing locations older than: 30 3: minutes -
OK Cancel

¢ Inthe dialog box, specify the following parameters:

* Maximum number of simultaneous requests
Specify the maximum number of radios being requested at the same
time.

= Retrieve missing locations if the data gap exceeds
TRBOnet Server automatically checks whether the location data is
continuous. If it detects data gaps between any consecutive location
data that exceed this value, it will attempt to retrieve missing
information.

= Don't retrieve missing locations older than
TRBOnet Server doesn't check location updates for consistency if they
are older than this value in seconds, minutes, or hours.

= On the Radios tab, specify the radio(s) to retrieve location data from.

¢ In the list of tasks, activate the Automatic Data Retrieval (Swift GPS)
task by selecting the box next to the task name.

5.4 Automatic Voice Download

The Automatic Voice Download task is used to automatically retrieve voice data
from the radio's option board when the radio is in WiFi zone.

e Go to Administration, Tasks.
e Inthe Tasks pane, click Add > Automatic Voice Download (Swift).

5 Using Option Board Features in Dispatch Console
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Automatic Voice Download (Swift)

Mame: |Voice Download

General Radios

Maximum number of simuttaneous requests: 3 3:

Save to |c:\

%RADIO_ID% L YEARCLMONTH L LDAY L HOUR L EMINUTE L SECOND %

Year Month Day Hour Minute Second Call Type Source Source Type

Source D Recipient Recipiert Tvpe Recipient ID  Radio 1D

Example:
c\Radio_120221130133744_xxx.tna

[ saveto database

{Mote that this may cause duplication of voice records in the server database)

Cancel

¢ Inthe dialog box, specify the following parameters:

= Maximum number of simultaneous requests
Specify the maximum number of simultaneously requested radios.

= Save to
Specify the path where to save voice data on your PC.

nheocom
software

= On the Radios tab, specify the radio(s) to retrieve voice data from.

In the list of tasks, activate the Automatic Voice Download (Swift) task by
selecting the check box next to the task name.

5.4 Automatic Voice Download

13
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